Atlassian Confluence < 7.19.16 / 8.x < 8.3.4 / 8.4.x < 8.4.4 / 8.5.x < 8.5.3 / 8.6.x < 8.6.1 (CONFSERVER-93142)

critical Nessus Plugin ID 184079


The remote Atlassian Confluence host is missing a security update.


The version of Atlassian Confluence Server running on the remote host is affected by a vulnerability as referenced in the CONFSERVER-93142 advisory.

- Improper Authorization in Confluence Data Center and Server (CVE-2023-22518)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Atlassian Confluence version 7.19.16, 8.3.4, 8.4.4, 8.5.3, 8.6.1 or later.

See Also

Plugin Details

Severity: Critical

ID: 184079

File Name: confluence_confserver-93142.nasl

Version: 1.11

Type: combined

Agent: windows, macosx, unix

Family: CGI abuses

Published: 10/31/2023

Updated: 6/5/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Critical

Score: 9.4


Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-22518


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Required KB Items: installed_sw/Atlassian Confluence

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/31/2023

Vulnerability Publication Date: 10/31/2023

CISA Known Exploited Vulnerability Due Dates: 11/28/2023

Exploitable With

Core Impact

Metasploit (Atlassian Confluence Unauth JSON setup-restore Improper Authorization leading to RCE (CVE-2023-22518))

Reference Information

CVE: CVE-2023-22518

IAVA: 2023-A-0588-S