GLSA-200506-01 : Binutils, elfutils: Buffer overflow

Medium Nessus Plugin ID 18406


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200506-01 (Binutils, elfutils: Buffer overflow)

Tavis Ormandy and Ned Ludd of the Gentoo Linux Security Audit Team discovered an integer overflow in the BFD library and elfutils, resulting in a heap based buffer overflow.
Impact :

Successful exploitation would require a user to access a specially crafted binary file, resulting in the execution of arbitrary code.
Workaround :

There is no known workaround at this time.


All GNU Binutils users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose sys-devel/binutils All elfutils users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/elfutils-0.108'

See Also

Plugin Details

Severity: Medium

ID: 18406

File Name: gentoo_GLSA-200506-01.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/06/02

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:binutils, p-cpe:/a:gentoo:linux:elfutils, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/06/01

Vulnerability Publication Date: 2005/05/20

Reference Information

CVE: CVE-2005-1704

OSVDB: 16757

GLSA: 200506-01