Mandrake Linux Security Advisory : gdb (MDKSA-2005:095)

High Nessus Plugin ID 18404


The remote Mandrake Linux host is missing a security update.


Tavis Ormandy of the Gentoo Linux Security Audit Team discovered two vulnerabilities in the GNU debugger. The first allows an attacker to execute arbitrary code with the privileges of the user running gdb if they can trick the user into loading a specially crafted executable (CVE-2005-1704).

He also discovered that gdb loads and executes the file .gdbinit in the current directory even if the file belongs to a different user. If a user can be tricked into running gdb in a directory with a malicious .gdbinit file, a local attacker can exploit this to run arbitrary commands with the privileges of the user running gdb (CVE-2005-1705).

The updated packages have been patched to correct these problems.


Update the affected gdb package.

Plugin Details

Severity: High

ID: 18404

File Name: mandrake_MDKSA-2005-095.nasl

Version: $Revision: 1.17 $

Type: local

Published: 2005/05/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gdb, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/05/30

Reference Information

CVE: CVE-2005-1704, CVE-2005-1705

MDKSA: 2005:095