GLSA-200505-18 : Net-SNMP: fixproc insecure temporary file creation

Critical Nessus Plugin ID 18382


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200505-18 (Net-SNMP: fixproc insecure temporary file creation)

The fixproc application of Net-SNMP creates temporary files with predictable filenames.
Impact :

A malicious local attacker could exploit a race condition to change the content of the temporary files before they are executed by fixproc, possibly leading to the execution of arbitrary code. A local attacker could also create symbolic links in the temporary files directory, pointing to a valid file somewhere on the filesystem. When fixproc is executed, this would result in the file being overwritten.
Workaround :

There is no known workaround at this time.


All Net-SNMP users should upgrade to the latest available version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-analyzer/net-snmp-5.2.1-r1'

See Also

Plugin Details

Severity: Critical

ID: 18382

File Name: gentoo_GLSA-200505-18.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/05/28

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:net-snmp, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/05/23

Vulnerability Publication Date: 2005/05/23

Reference Information

CVE: CVE-2005-1740

OSVDB: 16778

GLSA: 200505-18