Mac OS X < 10.4 pty Permission Weakness

Medium Nessus Plugin ID 18352


The remote version of the operating system contains a vulnerability which has been patched by the vendor in a newer release of the system


The remote host is running a version of Mac OS X which is older than version 10.4.

Versions older than 10.4 contain a security issue in the way they handle the permissions of pseudo terminals.

When an application uses a new pseudo terminal, it can not restrict its permissions to a safe mode. As a result, every created pseudo terminal has permissions 0666 set, which allows a local attacker to sniff the session of other users.


Upgrade to Mac OS X 10.4 or newer.

See Also

Plugin Details

Severity: Medium

ID: 18352

File Name: macosx_10_4.nasl

Version: $Revision: 1.13 $

Type: local

Agent: macosx

Published: 2005/05/20

Modified: 2016/11/28

Dependencies: 12634, 12218

Risk Information

Risk Factor: Medium


Base Score: 6.6

Temporal Score: 6.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:N

Temporal Vector: CVSS2#E:H/RL:U/RC:ND

Vulnerability Information

CPE: cpe:/o:apple:mac_os_x

Required KB Items: Host/MacOSX/packages

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2005/05/01

Vulnerability Publication Date: 2005/05/01

Reference Information

CVE: CVE-2005-1430

BID: 13467

OSVDB: 16254