Fedora Core 2 : squid-2.5.STABLE9-1.FC2.2 (2005-275)

High Nessus Plugin ID 18329


The remote Fedora Core host is missing a security update.


- Tue Mar 29 2005 Jay Fenlason <fenlason at redhat.com> 7:2.5.STABLE9-1.FC3.2

- more upstream patches

- include -libbind patch, to prevent squid from picking up a dependency on libbind.

- remove references to /etc/squid/errors, since squid now uses {_datadir}/squid/errors/English by default.
(overridable in squid.conf)

- Mark {datadir}/squid/errors as config(noreplace) so custom error messages won't get scribbled on.

- Wed Mar 16 2005 Jay Fenlason <fenlason at redhat.com> 7:2.5.STABLE9-1.FC3.1

- New upstream version, with 14 upstream patches. Includes fix for bz#150234 cookie leak in squid

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected squid and / or squid-debuginfo packages.

See Also


Plugin Details

Severity: High

ID: 18329

File Name: fedora_2005-275.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2005/05/19

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:squid, p-cpe:/a:fedoraproject:fedora:squid-debuginfo, cpe:/o:fedoraproject:fedora_core:2

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2005/03/30

Reference Information

FEDORA: 2005-275