Mandrake Linux Security Advisory : gnutls (MDKSA-2005:084)

Medium Nessus Plugin ID 18273


The remote Mandrake Linux host is missing one or more security updates.


Two vulnerabilities were discovered in the GnuTLS library. The first is a vulnerability in the way GnuTLS does record packet parsing; the second is a flaw in the RSA key export functionality. These could be exploited by a remote attacker to cause a Denial of Service to any program using the GnuTLS library.

The provided packages have been patched to correct these issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 18273

File Name: mandrake_MDKSA-2005-084.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/05/17

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gnutls, p-cpe:/a:mandriva:linux:lib64gnutls11, p-cpe:/a:mandriva:linux:lib64gnutls11-devel, p-cpe:/a:mandriva:linux:libgnutls11, p-cpe:/a:mandriva:linux:libgnutls11-devel, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/05/12

Reference Information

CVE: CVE-2005-1431

MDKSA: 2005:084