Apache Spark < 3.2.2 / 3.3.0 < 3.3.1 XSS (CVE-2022-31777)

medium Nessus Plugin ID 182513


The remote host contains a web application that is affected by a cross-site scripting vulnerability.


The version of Apache Spark installed on the remote host is prior to 3.2.2 or is 3.3.0. It is, therefore, affected by a cross-site scripting (XSS) vulnerability. An authenticated, remote attacker can execute arbitrary JavaScript in the web browser of a user by including a malicious payload into the logs which would be returned in logs rendered in the UI.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade Apache Spark to 3.2.2, 3.3.1, or later.

See Also


Plugin Details

Severity: Medium

ID: 182513

File Name: apache_spark_CVE-2022-31777.nasl

Version: 1.2

Type: remote

Family: Misc.

Published: 10/4/2023

Updated: 5/28/2024

Supported Sensors: Nessus

Risk Information


Risk Factor: Low

Score: 3.0


Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

CVSS Score Source: CVE-2022-31777


Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:spark

Required KB Items: installed_sw/Apache Spark

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No known exploits are available

Patch Publication Date: 10/25/2022

Vulnerability Publication Date: 11/1/2022

Reference Information

CVE: CVE-2022-31777