Apache Spark < 3.4.0 Privilege Escalation (CVE-2023-22946)

critical Nessus Plugin ID 182512


The remote host contains a web application that is affected by a privilege escalation vulnerability.


In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications. Update to Apache Spark 3.4.0 or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of 'false', and is not overridden by submitted applications.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade Apache Spark to 3.4.0, or later and ensure the configuration is set as specified in the vendor advisory.

See Also


Plugin Details

Severity: Critical

ID: 182512

File Name: apache_spark_CVE-2023-22946.nasl

Version: 1.2

Type: remote

Family: Misc.

Published: 10/4/2023

Updated: 5/28/2024

Supported Sensors: Nessus

Risk Information


Risk Factor: High

Score: 7.3


Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2023-22946


Risk Factor: Critical

Base Score: 9.9

Temporal Score: 8.6

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:spark

Required KB Items: installed_sw/Apache Spark

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No known exploits are available

Patch Publication Date: 4/13/2020

Vulnerability Publication Date: 4/15/2023

Reference Information

CVE: CVE-2023-22946