Firefox < 1.0.4 Multiple Vulnerabilities

high Nessus Plugin ID 18243
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host contains a web browser that is affected by multiple vulnerabilities.

Description

The installed version of Firefox is earlier than 1.0.4. Such versions have multiple vulnerabilities that may allow arbitrary code execution.

Solution

Upgrade to Firefox 1.0.4 or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2005-43/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-44/

https://www.mozilla.org/en-US/security/advisories/mfsa2005-42/

Plugin Details

Severity: High

ID: 18243

File Name: mozilla_firefox_104.nasl

Version: 1.28

Type: local

Agent: windows

Family: Windows

Published: 5/12/2005

Updated: 7/16/2018

Dependencies: mozilla_org_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:*

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/11/2005

Vulnerability Publication Date: 5/7/2005

Reference Information

CVE: CVE-2005-1476, CVE-2005-1477, CVE-2005-1531, CVE-2005-1532

BID: 13544, 13641, 13645