GitLab 16.0.0 < 16.2.8 / 16.3 < 16.3.5 / 16.4 < 16.4.1 (CVE-2023-5207)

high Nessus Plugin ID 182352

Synopsis

The version of GitLab installed on the remote host is affected by a vulnerability.

Description

The version of GitLab installed on the remote host is affected by a vulnerability, as follows:

- A vulnerability was discovered in GitLab CE and EE affecting all versions starting 16.0 prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1. An authenticated attacker could perform arbitrary pipeline execution under the context of another user. (CVE-2023-5207)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 16.2.8, 16.3.5, 16.4.1 or later.

See Also

http://www.nessus.org/u?7a1b473e

https://gitlab.com/gitlab-org/gitlab/-/issues/425604

https://gitlab.com/gitlab-org/gitlab/-/issues/425857

https://hackerone.com/reports/2174141

Plugin Details

Severity: High

ID: 182352

File Name: gitlab_cve-2023-5207.nasl

Version: 1.7

Type: combined

Agent: unix

Family: CGI abuses

Published: 9/29/2023

Updated: 5/17/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2023-5207

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 9/28/2023

Vulnerability Publication Date: 9/28/2023

Reference Information

CVE: CVE-2023-5207

IAVA: 2023-A-0518-S