GLSA-200505-05 : gzip: Multiple vulnerabilities

Medium Nessus Plugin ID 18231

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.5

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200505-05 (gzip: Multiple vulnerabilities)

The gzip and gunzip programs are vulnerable to a race condition when setting file permissions (CAN-2005-0988), as well as improper handling of filename restoration (CAN-2005-1228). The zgrep utility improperly sanitizes arguments, which may come from an untrusted source (CAN-2005-0758).
Impact :

These vulnerabilities could allow arbitrary command execution, changing the permissions of arbitrary files, and installation of files to an aribitrary location in the filesystem.
Workaround :

There is no known workaround at this time.

Solution

All gzip users should upgrade to the latest stable version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-arch/gzip-1.3.5-r6'

See Also

https://security.gentoo.org/glsa/200505-05

Plugin Details

Severity: Medium

ID: 18231

File Name: gentoo_GLSA-200505-05.nasl

Version: 1.15

Type: local

Published: 2005/05/11

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 5.5

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gzip, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/05/09

Vulnerability Publication Date: 2005/04/04

Reference Information

CVE: CVE-2005-0758, CVE-2005-0988, CVE-2005-1228

GLSA: 200505-05