Apache Struts SEoL (2.3.0.x <= x <= 2.3.37.x)

critical Nessus Plugin ID 182281


An unsupported version of Apache Struts is installed on the remote host.


According to its version, Apache Struts is between 2.3.0.x and 2.3.37.x. It is, therefore, no longer maintained by its vendor or provider.

Lack of support implies that no new security patches for the product will be released by the vendor. As a result, it may contain security vulnerabilities.


Upgrade to a version of Apache Struts that is currently supported.

See Also


Plugin Details

Severity: Critical

ID: 182281

File Name: struts_2_3_37_seol.nasl

Version: 1.1

Type: combined

Agent: windows, macosx, unix

Family: Misc.

Published: 9/29/2023

Updated: 11/2/2023

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information

CVSS Score Rationale: Tenable standard unsupported software score.


Risk Factor: Critical

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: manual


Risk Factor: Critical

Base Score: 10

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: installed_sw/Apache Struts