GLSA-200505-02 : Oops!: Remote code execution

Medium Nessus Plugin ID 18228


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200505-02 (Oops!: Remote code execution)

A format string flaw has been detected in the my_xlog() function of the Oops! proxy, which is called by the passwd_mysql and passwd_pgsql module's auth() functions.
Impact :

A remote attacker could send a specially crafted HTTP request to the Oops! proxy, potentially triggering this vulnerability and leading to the execution of arbitrary code.
Workaround :

There is no known workaround at this time.


All Oops! users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-proxy/oops-1.5.24_pre20050503'

See Also

Plugin Details

Severity: Medium

ID: 18228

File Name: gentoo_GLSA-200505-02.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2005/05/11

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:oops, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/05/05

Vulnerability Publication Date: 2005/04/14

Reference Information

CVE: CVE-2005-1121

OSVDB: 16087

GLSA: 200505-02