OpenSSL SEoL (3.1.x)

low Nessus Plugin ID 182210

Synopsis

An unsupported version of OpenSSL is installed on the remote host.

Description

According to its version, OpenSSL is 3.1.x. It is, therefore, no longer maintained by its vendor or provider.

Lack of support implies that no new security patches for the product will be released by the vendor. As a result, it may contain security vulnerabilities.

Solution

Upgrade to a version of OpenSSL that is currently supported.

See Also

https://www.openssl.org/policies/releasestrat.html

https://www.openssl.org/news/vulnerabilities-3.1.html

Plugin Details

Severity: Low

ID: 182210

File Name: openssl_3_1_seol.nasl

Version: 1.3

Type: combined

Family: Misc.

Published: 9/29/2023

Updated: 5/31/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus

Risk Information

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: installed_sw/OpenSSL