Mandrake Linux Security Advisory : xpm (MDKSA-2005:080)

High Nessus Plugin ID 18173


The remote Mandrake Linux host is missing one or more security updates.


The XPM library which is part of the XFree86/XOrg project is used by several GUI applications to process XPM image files.

An integer overflow flaw was found in libXPM, which is used by some applications for loading of XPM images. An attacker could create a malicious XPM file that would execute arbitrary code via a negative bitmap_unit value if opened by a victim using an application linked to the vulnerable library.

Updated packages are patched to correct all these issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 18173

File Name: mandrake_MDKSA-2005-080.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/05/02

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64xpm4, p-cpe:/a:mandriva:linux:lib64xpm4-devel, p-cpe:/a:mandriva:linux:libxpm4, p-cpe:/a:mandriva:linux:libxpm4-devel, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/04/28

Reference Information

CVE: CVE-2005-0605

MDKSA: 2005:080