GLSA-200504-29 : Pound: Buffer overflow vulnerability

High Nessus Plugin ID 18168


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200504-29 (Pound: Buffer overflow vulnerability)

Steven Van Acker has discovered a buffer overflow vulnerability in the 'add_port()' function in Pound.
Impact :

A remote attacker could send a request for an overly long hostname parameter, which could lead to the remote execution of arbitrary code with the rights of the Pound daemon process (by default, Gentoo uses the 'nobody' user to run the Pound daemon).
Workaround :

There is no known workaround at this time.


All Pound users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-servers/pound-1.8.3'

See Also

Plugin Details

Severity: High

ID: 18168

File Name: gentoo_GLSA-200504-29.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/05/02

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:pound, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/04/30

Vulnerability Publication Date: 2005/04/26

Reference Information

CVE: CVE-2005-1391

OSVDB: 15963

GLSA: 200504-29