GLSA-200504-26 : Convert-UUlib: Buffer overflow

High Nessus Plugin ID 18144


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200504-26 (Convert-UUlib: Buffer overflow)

A vulnerability has been reported in Convert-UUlib where a malformed parameter can be provided by an attacker allowing a read operation to overflow a buffer. The vendor credits Mark Martinec and Robert Lewis with the discovery.
Impact :

Successful exploitation would permit an attacker to run arbitrary code with the privileges of the user running the Perl application.
Workaround :

There is no known workaround at this time.


All Convert-UUlib users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-perl/Convert-UUlib-1.051'

See Also

Plugin Details

Severity: High

ID: 18144

File Name: gentoo_GLSA-200504-26.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/04/27

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:Convert-UUlib, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/04/26

Vulnerability Publication Date: 2005/04/26

Reference Information

CVE: CVE-2005-1349

OSVDB: 15867, 31791

GLSA: 200504-26