Apache Struts 2.0.0 < 2.5.32 / 6.0.0 < Denial of Service (S2-065)

high Nessus Plugin ID 181347


Apache Struts installed on the remote host is affected by Denial of Service vulnerability


The version of Apache Struts installed on the remote host is prior to 2.5.32 or It is, therefore, affected by a vulnerability as referenced in the S2-065 advisory.

- When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. (CVE-2023-41835)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Struts version 2.5.32 or or later. Alternatively, apply the workaround as referenced in in the vendor's security bulletin

See Also


Plugin Details

Severity: High

ID: 181347

File Name: struts_S2-065.nasl

Version: 1.6

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 9/13/2023

Updated: 12/15/2023

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2023-41835


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:struts

Exploit Ease: No known exploits are available

Patch Publication Date: 9/11/2023

Vulnerability Publication Date: 9/11/2023

Reference Information

CVE: CVE-2023-41835

IAVA: 2023-A-0492-S