Adobe Reader < 20.005.30524 / 23.006.20320 Vulnerability (APSB23-34) (macOS)

high Nessus Plugin ID 181273

Synopsis

The version of Adobe Reader installed on the remote macOS host is affected by a vulnerability.

Description

The version of Adobe Reader installed on the remote macOS host is a version prior to 20.005.30524 or 23.006.20320. It is, therefore, affected by a vulnerability.

- Out-of-bounds Write (CWE-787) potentially leading to Arbitrary code execution (CVE-2023-26369)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe Reader version 20.005.30524 / 23.006.20320 or later.

See Also

https://helpx.adobe.com/security/products/acrobat/apsb23-34.html

Plugin Details

Severity: High

ID: 181273

File Name: macos_adobe_reader_apsb23-34.nasl

Version: 1.6

Type: local

Agent: unix

Published: 9/12/2023

Updated: 11/16/2023

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 8.4

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-26369

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 7.2

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe Reader

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/12/2023

Vulnerability Publication Date: 9/12/2023

CISA Known Exploited Vulnerability Due Dates: 10/5/2023

Reference Information

CVE: CVE-2023-26369

CWE: 787

IAVA: 2023-A-0473-S