GLSA-200504-24 : eGroupWare: XSS and SQL injection vulnerabilities

High Nessus Plugin ID 18127


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200504-24 (eGroupWare: XSS and SQL injection vulnerabilities)

Multiple SQL injection and cross-site scripting vulnerabilities have been found in several eGroupWare modules.
Impact :

An attacker could possibly use the SQL injection vulnerabilities to gain information from the database. Furthermore the cross-site scripting issues give an attacker the ability to inject and execute malicious script code or to steal cookie based authentication credentials, potentially compromising the victim's browser.
Workaround :

There is no known workaround at this time.


All eGroupWare users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/egroupware-'

See Also

Plugin Details

Severity: High

ID: 18127

File Name: gentoo_GLSA-200504-24.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2005/04/25

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:egroupware, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/04/25

Vulnerability Publication Date: 2005/04/15

Reference Information

CVE: CVE-2005-1202, CVE-2005-1203

OSVDB: 15649, 15750, 15751, 15752, 15753

GLSA: 200504-24