Amazon Linux 2023 : postgresql15, postgresql15-contrib, postgresql15-llvmjit (ALAS2023-2023-322)

high Nessus Plugin ID 181141

Synopsis

The remote Amazon Linux 2023 host is missing a security update.

Description

It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2023-322 advisory.

- IN THE EXTENSION SCRIPT, a SQL Injection vulnerability was found in PostgreSQL if it uses @extowner@, @extschema@, or @extschema:...@ inside a quoting construct (dollar quoting, '', or ). If an administrator has installed files of a vulnerable, trusted, non-bundled extension, an attacker with database-level CREATE privilege can execute arbitrary code as the bootstrap superuser. (CVE-2023-39417)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'dnf update postgresql15 --releasever 2023.1.20230906' to update your system.

See Also

https://alas.aws.amazon.com/AL2023/ALAS-2023-322.html

https://alas.aws.amazon.com/cve/html/CVE-2023-39417.html

https://alas.aws.amazon.com/faqs.html

Plugin Details

Severity: High

ID: 181141

File Name: al2023_ALAS2023-2023-322.nasl

Version: 1.5

Type: local

Agent: unix

Published: 9/8/2023

Updated: 12/25/2023

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2023-39417

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:postgresql15-test-rpm-macros, p-cpe:/a:amazon:linux:postgresql15-upgrade, p-cpe:/a:amazon:linux:postgresql15-upgrade-debuginfo, p-cpe:/a:amazon:linux:postgresql15-upgrade-devel, p-cpe:/a:amazon:linux:postgresql15-upgrade-devel-debuginfo, cpe:/o:amazon:linux:2023, p-cpe:/a:amazon:linux:postgresql15, p-cpe:/a:amazon:linux:postgresql15-contrib, p-cpe:/a:amazon:linux:postgresql15-contrib-debuginfo, p-cpe:/a:amazon:linux:postgresql15-debuginfo, p-cpe:/a:amazon:linux:postgresql15-debugsource, p-cpe:/a:amazon:linux:postgresql15-docs, p-cpe:/a:amazon:linux:postgresql15-docs-debuginfo, p-cpe:/a:amazon:linux:postgresql15-llvmjit, p-cpe:/a:amazon:linux:postgresql15-llvmjit-debuginfo, p-cpe:/a:amazon:linux:postgresql15-plperl, p-cpe:/a:amazon:linux:postgresql15-plperl-debuginfo, p-cpe:/a:amazon:linux:postgresql15-plpython3, p-cpe:/a:amazon:linux:postgresql15-plpython3-debuginfo, p-cpe:/a:amazon:linux:postgresql15-pltcl, p-cpe:/a:amazon:linux:postgresql15-pltcl-debuginfo, p-cpe:/a:amazon:linux:postgresql15-private-devel, p-cpe:/a:amazon:linux:postgresql15-private-libs, p-cpe:/a:amazon:linux:postgresql15-private-libs-debuginfo, p-cpe:/a:amazon:linux:postgresql15-server, p-cpe:/a:amazon:linux:postgresql15-server-debuginfo, p-cpe:/a:amazon:linux:postgresql15-server-devel, p-cpe:/a:amazon:linux:postgresql15-server-devel-debuginfo, p-cpe:/a:amazon:linux:postgresql15-static, p-cpe:/a:amazon:linux:postgresql15-test, p-cpe:/a:amazon:linux:postgresql15-test-debuginfo

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 8/31/2023

Vulnerability Publication Date: 8/10/2023

Reference Information

CVE: CVE-2023-39417

IAVB: 2023-B-0060-S