Mandrake Linux Security Advisory : gnome-vfs2 (MDKSA-2005:074)

High Nessus Plugin ID 18104


The remote Mandrake Linux host is missing one or more security updates.


A buffer overflow bug was found by Joseph VanAndel in the way that grip handles data returned by CDDB servers. If a user connected to a malicious CDDB server, an attacker could execute arbitrary code on the user's machine. This same vulnerability is present in the gnome-vfs2 code.

The updated packages have been patched to correct these issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 18104

File Name: mandrake_MDKSA-2005-074.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/04/21

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gnome-vfs2, p-cpe:/a:mandriva:linux:lib64gnome-vfs2_0, p-cpe:/a:mandriva:linux:lib64gnome-vfs2_0-devel, p-cpe:/a:mandriva:linux:libgnome-vfs2_0, p-cpe:/a:mandriva:linux:libgnome-vfs2_0-devel, cpe:/o:mandrakesoft:mandrake_linux:10.1, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/04/20

Reference Information

CVE: CVE-2005-0706

MDKSA: 2005:074