MS05-023: Vulnerability in Word May Lead to Code Execution (890169)

High Nessus Plugin ID 18026


Arbitrary code can be executed on the remote host through Word.


The remote host is running a version of Microsoft Word that could allow arbitrary code to be run.

To succeed, the attacker would have to send a rogue Word file to a user of the remote computer and have it open it. Then the macros contained in the Word file would bypass the security model of Word, and would be executed.


Microsoft has released a set of patches for Word 2000, 2002 and 2003.

See Also

Plugin Details

Severity: High

ID: 18026

File Name: smb_nt_ms05-023.nasl

Version: $Revision: 1.36 $

Type: local

Agent: windows

Published: 2005/04/12

Modified: 2017/08/09

Dependencies: 18679, 11322, 11336

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:ND/RC:ND

Vulnerability Information

CPE: cpe:/a:microsoft:word, cpe:/a:microsoft:office

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2005/04/12

Vulnerability Publication Date: 2004/10/08

Reference Information

CVE: CVE-2004-0963, CVE-2005-0558

BID: 13122, 13119

OSVDB: 10549, 15470

MSFT: MS05-023

MSKB: 887978, 891067