GitLab 16.1 < 16.1.3 / 16.2 < 16.2.2 (CVE-2023-3900)

high Nessus Plugin ID 179172


The version of GitLab installed on the remote host is affected by a vulnerability.


The version of GitLab installed on the remote host is affected by a vulnerability, as follows:

- An issue has been discovered in GitLab CE/EE affecting all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. An invalid 'start_sha' value on merge requests page may lead to Denial of Service as Changes tab would not load. (CVE-2023-3900)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to GitLab version 16.1.3, 16.2.2 or later.

See Also

Plugin Details

Severity: High

ID: 179172

File Name: gitlab_cve-2023-3900.nasl

Version: 1.6

Type: combined

Agent: unix

Family: CGI abuses

Published: 8/1/2023

Updated: 5/17/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2023-3900


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 8/1/2023

Vulnerability Publication Date: 8/1/2023

Reference Information

CVE: CVE-2023-3900

IAVA: 2023-A-0389-S