RHEL 9 : postgresql:15 (RHSA-2023:4327)

high Nessus Plugin ID 179057

Synopsis

The remote Red Hat host is missing one or more security updates for postgresql:15.

Description

The remote Redhat Enterprise Linux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2023:4327 advisory.

- schema_element defeats protective search_path changes; It was found that certain database calls in PostgreSQL could permit an authed attacker with elevated database-level privileges to execute arbitrary code. (CVE-2023-2454)

- Row security policies disregard user ID changes after inlining; PostgreSQL could permit incorrect policies to be applied in certain cases where role-specific policies are used and a given query is planned under one role and then executed under other roles. This scenario can happen under security definer functions or when a common user and query is planned initially and then re-used across multiple SET ROLEs. Applying an incorrect policy may permit a user to complete otherwise-forbidden reads and modifications. This affects only databases that have used CREATE POLICY to define a row security policy. (CVE-2023-2455)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the RHEL postgresql:15 package based on the guidance in RHSA-2023:4327.

See Also

https://access.redhat.com/security/cve/CVE-2023-2454

https://access.redhat.com/security/cve/CVE-2023-2455

https://access.redhat.com/errata/RHSA-2023:4327

Plugin Details

Severity: High

ID: 179057

File Name: redhat-RHSA-2023-4327.nasl

Version: 1.2

Type: local

Agent: unix

Published: 7/31/2023

Updated: 1/26/2024

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 8.3

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:M/C:C/I:C/A:C

CVSS Score Source: CVE-2023-2454

CVSS v3

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:redhat:enterprise_linux:9, cpe:/o:redhat:rhel_aus:9.2, cpe:/o:redhat:rhel_e4s:9.2, cpe:/o:redhat:rhel_eus:9.2, p-cpe:/a:redhat:enterprise_linux:pg_repack, p-cpe:/a:redhat:enterprise_linux:pgaudit, p-cpe:/a:redhat:enterprise_linux:postgres-decoderbufs, p-cpe:/a:redhat:enterprise_linux:postgresql, p-cpe:/a:redhat:enterprise_linux:postgresql-contrib, p-cpe:/a:redhat:enterprise_linux:postgresql-docs, p-cpe:/a:redhat:enterprise_linux:postgresql-plperl, p-cpe:/a:redhat:enterprise_linux:postgresql-plpython3, p-cpe:/a:redhat:enterprise_linux:postgresql-pltcl, p-cpe:/a:redhat:enterprise_linux:postgresql-private-devel, p-cpe:/a:redhat:enterprise_linux:postgresql-private-libs, p-cpe:/a:redhat:enterprise_linux:postgresql-server, p-cpe:/a:redhat:enterprise_linux:postgresql-server-devel, p-cpe:/a:redhat:enterprise_linux:postgresql-static, p-cpe:/a:redhat:enterprise_linux:postgresql-test, p-cpe:/a:redhat:enterprise_linux:postgresql-test-rpm-macros, p-cpe:/a:redhat:enterprise_linux:postgresql-upgrade, p-cpe:/a:redhat:enterprise_linux:postgresql-upgrade-devel

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 7/31/2023

Vulnerability Publication Date: 5/11/2023

Reference Information

CVE: CVE-2023-2454, CVE-2023-2455

CWE: 20

IAVB: 2023-B-0034-S

RHSA: 2023:4327