Rocky Linux 8 : libssh (RLSA-2023:3839)

medium Nessus Plugin ID 178050

Synopsis

The remote Rocky Linux host is missing one or more security updates.

Description

The remote Rocky Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RLSA-2023:3839 advisory.

- A NULL pointer dereference was found In libssh during re-keying with algorithm guessing. This issue may allow an authenticated client to cause a denial of service. (CVE-2023-1667)

- A vulnerability was found in libssh, where the authentication check of the connecting client can be bypassed in the`pki_verify_data_signature` function in memory allocation problems. This issue may happen if there is insufficient memory or the memory usage is limited. The problem is caused by the return value `rc,` which is initialized to SSH_ERROR and later rewritten to save the return value of the function call `pki_key_check_hash_compatible.` The value of the variable is not changed between this point and the cryptographic verification. Therefore any error between them calls `goto error` returning SSH_OK.
(CVE-2023-2283)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://errata.rockylinux.org/RLSA-2023:3839

https://bugzilla.redhat.com/show_bug.cgi?id=2182199

https://bugzilla.redhat.com/show_bug.cgi?id=2189736

Plugin Details

Severity: Medium

ID: 178050

File Name: rocky_linux_RLSA-2023-3839.nasl

Version: 1.3

Type: local

Published: 7/8/2023

Updated: 12/22/2023

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2023-2283

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:rocky:linux:libssh, p-cpe:/a:rocky:linux:libssh-devel, p-cpe:/a:rocky:linux:libssh-debugsource, p-cpe:/a:rocky:linux:libssh-debuginfo, p-cpe:/a:rocky:linux:libssh-config, cpe:/o:rocky:linux:8

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RockyLinux/release, Host/RockyLinux/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 7/8/2023

Vulnerability Publication Date: 5/15/2023

Reference Information

CVE: CVE-2023-1667, CVE-2023-2283

IAVA: 2023-A-0517-S