OpenSSL < 0.9.2b Session Reuse

high Nessus Plugin ID 17798


The remote server is vulnerable to an SSL session reuse attack.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.2b.

A remote attacker could reuse an SSL session under a different context and bypass access control mechanisms based on client certificates.


Upgrade to OpenSSL 0.9.8s or later as the 0.9.2 branch is no longer supported.

See Also

Plugin Details

Severity: High

ID: 17798

File Name: openssl_0_9_2b.nasl

Version: 1.9

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 1/12/2012

Updated: 8/22/2023

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 5.2


Risk Factor: High

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-1999-0428

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: installed_sw/OpenSSL

Patch Publication Date: 3/22/1999

Vulnerability Publication Date: 3/22/1999

Reference Information

CVE: CVE-1999-0428

BID: 82466