PHP 4.x < 4.3.0 ZendEngine Integer Overflow

high Nessus Plugin ID 17796


Arbitrary code may be run on the remote server.


The remote host is running a version of PHP 4.x older than 4.3.0. As such, it reportedly has an integer overflow in array creation that can be triggered by user-input passed to an 'unserialize()' function.

Successful exploitation of this vulnerability could allow an attacker to execute arbitrary code on this host.


Upgrade to PHP 4.3.0 or later.

See Also

Plugin Details

Severity: High

ID: 17796

File Name: php_4_3_0_zendengine.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 1/11/2012

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Vulnerability Publication Date: 10/5/2006

Reference Information

CVE: CVE-2006-4812

BID: 20349

CWE: 94