OpenSSL 1.0.0 < 1.0.0-beta2 DoS

Medium Nessus Plugin ID 17768


The remote server is affected by a denial of service vulnerability.


According to its banner, the remote server is running a version of OpenSSL 1.0.0 prior to 1.0.0 beta 2.

A remote attacker can crash the server by sending an out-of-sequence DTLS handshake message.


Upgrade to OpenSSL 1.0.0 or later.

See Also

Plugin Details

Severity: Medium

ID: 17768

File Name: openssl_1_0_0.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2014/09/22

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/04/14

Vulnerability Publication Date: 2009/02/05

Reference Information

CVE: CVE-2009-1379, CVE-2009-1387

BID: 35138, 35417

OSVDB: 54614, 55072

CWE: 399