OpenSSL < 0.9.8p / 1.0.0e Double Free Vulnerability

Medium Nessus Plugin ID 17767

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 4.2

Synopsis

The remote SSL layer is affected by a denial of service vulnerability.

Description

According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.8p / 1.0.0e.

A remote attacker could crash client software when using ECDH. The impact of this vulnerability is not clear; arbitrary code could be run too.

Note that OpenSSL changelog only reports a fix for 0.9.8p. 1.0.0a is definitely vulnerable. Gentoo reports a fix for 1.0.0e but it covers other flaws.NVD reports 0.9.7 as vulnerable too but does not give any fixed version.

Solution

Upgrade to OpenSSL 0.9.8p / 1.0.0e or later.

See Also

https://www.mail-archive.com/[email protected]/msg28049.html

Plugin Details

Severity: Medium

ID: 17767

File Name: openssl_0_9_8p_1_0_0e.nasl

Version: 1.9

Type: remote

Family: Web Servers

Published: 2012/01/04

Updated: 2018/11/15

Dependencies: 57323

Risk Information

Risk Factor: Medium

VPR Score: 4.2

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/09/06

Vulnerability Publication Date: 2010/08/07

Reference Information

CVE: CVE-2010-2939

BID: 42306

GLSA: 201110-01