OpenSSL < 0.9.8p / 1.0.0e Double Free Vulnerability

medium Nessus Plugin ID 17767


The remote SSL layer is affected by a denial of service vulnerability.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.8p / 1.0.0e.

A remote attacker could crash client software when using ECDH. The impact of this vulnerability is not clear; arbitrary code could be run too.

Note that OpenSSL changelog only reports a fix for 0.9.8p. 1.0.0a is definitely vulnerable. Gentoo reports a fix for 1.0.0e but it covers other flaws.NVD reports 0.9.7 as vulnerable too but does not give any fixed version.


Upgrade to OpenSSL 0.9.8p / 1.0.0e or later.

See Also[email protected]/msg28049.html

Plugin Details

Severity: Medium

ID: 17767

File Name: openssl_0_9_8p_1_0_0e.nasl

Version: 1.9

Type: remote

Family: Web Servers

Published: 1/4/2012

Updated: 11/15/2018

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 4.2


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/6/2011

Vulnerability Publication Date: 8/7/2010

Reference Information

CVE: CVE-2010-2939

BID: 42306

GLSA: 201110-01