OpenSSL < 0.9.8l Multiple Vulnerabilities

Medium Nessus Plugin ID 17765


The remote server is affected by multiple vulnerabilities.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.8l. As such, it may be affected by multiple vulnerabilities :

- A remote attacker could crash the server by sending malformed ASN.1 data. This flaw only affects some architectures, Win64 and other unspecified platforms. (CVE-2009-0789)

- A remote attacker could saturate the server by sending a big number of 'future epoch' DTLS records. (CVE-2009-1377)

- A remote attacker could saturate the server by sending duplicate DTLS records, or DTLS records with too big sequence numbers. (CVE-2009-1378)

- A remote attacker could spoof certificates by computing MD2 hash collisions. (CVE-2009-2409)


Upgrade to OpenSSL 0.9.8l or later.

See Also

Plugin Details

Severity: Medium

ID: 17765

File Name: openssl_0_9_8l.nasl

Version: $Revision: 1.16 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/11/05

Vulnerability Publication Date: 2009/05/15

Reference Information

CVE: CVE-2009-0789, CVE-2009-1377, CVE-2009-1378, CVE-2009-2409

BID: 34256, 35001

OSVDB: 52866, 54612, 54613, 56752

EDB-ID: 8720

CWE: 119, 189, 310, 399