OpenSSL < 0.9.8k Signature Repudiation

Low Nessus Plugin ID 17764


The remote server is affected by a signature repudiation vulnerability.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.8k. As such, it may allow a valid sign to generate invalid signatures which would appear valid and could be repudiated later.

This only affects CMS users. CMS appeared in OpenSSL 0.9.8h.


Upgrade to OpenSSL 0.9.8k or later.

See Also

Plugin Details

Severity: Low

ID: 17764

File Name: openssl_0_9_8k_CMS.nasl

Version: $Revision: 1.9 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: Low


Base Score: 2.6

Temporal Score: 2.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/03/25

Vulnerability Publication Date: 2009/03/25

Reference Information

CVE: CVE-2009-0591

BID: 34256

OSVDB: 52865

CWE: 287