OpenSSL < 0.9.8k Multiple Vulnerabilities

Medium Nessus Plugin ID 17763

Synopsis

The remote server is affected by multiple vulnerabilities.

Description

According to its banner, the remote server is running a version of OpenSSL prior to 0.9.8k. It is, therefore, affected by multiple vulnerabilities :

- A denial of service vulnerability exists in the ASN1_STRING_print_ex() function due to improper string handling. A remote attacker can exploit this to cause an invalid memory access and application crash.
(CVE-2009-0590)

- A flaw exists in the CMS_verify() function due to improper handling of errors associated with malformed signed attributes. A remote attacker can exploit this to repudiate a signature that originally appeared to be valid but was actually invalid. (CVE-2009-0591)

- A denial of service vulnerability exists due to improper handling of malformed ASN.1 structures. A remote attacker can exploit this to cause an invalid memory access and application crash. (CVE-2009-0789)

- A memory leak exists in the SSL_free() function in ssl_lib.c. A remote attacker can exploit this to exhaust memory resources, resulting in a denial of service condition. (CVE-2009-5146)

Solution

Upgrade to OpenSSL version 0.9.8k or later.

See Also

https://www.openssl.org/news/secadv/20090325.txt

Plugin Details

Severity: Medium

ID: 17763

File Name: openssl_0_9_8k.nasl

Version: 1.13

Type: remote

Family: Web Servers

Published: 2012/01/04

Updated: 2018/07/16

Dependencies: 57323

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/03/25

Vulnerability Publication Date: 2009/03/25

Reference Information

CVE: CVE-2009-0590, CVE-2009-0591, CVE-2009-0789, CVE-2009-5146

BID: 34256, 73121

CWE: 119, 189, 287