OpenSSL < 0.9.8j Signature Spoofing

Medium Nessus Plugin ID 17762


The remote server is affected by a signature validation bypass vulnerability.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.8j.

A remote attacker could implement a man-in-the-middle attack by forging an SSL/TLS signature using DSA and ECDSA keys which bypass validation of the certificate chain.


Upgrade to OpenSSL 0.9.8j or later.

See Also

Plugin Details

Severity: Medium

ID: 17762

File Name: openssl_0_9_8j.nasl

Version: $Revision: 1.7 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 5.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/01/07

Vulnerability Publication Date: 2009/01/07

Reference Information

CVE: CVE-2008-5077

BID: 33150

OSVDB: 51164

CWE: 20