OpenSSL < 0.9.8i Denial of Service

Medium Nessus Plugin ID 17761


The remote server is affected by a denial of service vulnerability.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.8i.

A remote attacker can crash the server by sending a DTLS ChangeCipherSpec packet before the ClientHello.


Upgrade to OpenSSL 0.9.8i or later.

See Also

Plugin Details

Severity: Medium

ID: 17761

File Name: openssl_0_9_8i.nasl

Version: $Revision: 1.11 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/09/15

Vulnerability Publication Date: 2009/04/23

Exploitable With

Core Impact

Reference Information

CVE: CVE-2009-1386

BID: 35174

OSVDB: 55073

EDB-ID: 8873