OpenSSL < 0.9.8 Weak Default Configuration

medium Nessus Plugin ID 17759
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The default configuration of OpenSSL on the remote server uses a weak hash algorithm.

Description

According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.8.

The default configuration uses MD5 instead of a stronger hash algorithm. An attacker could forge certificates.

If you never generate certificates on this machine, you may ignore this warning.

Solution

Upgrade to OpenSSL 0.9.8 or later.

See Also

https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/19835

https://usn.ubuntu.com/179-1/

Plugin Details

Severity: Medium

ID: 17759

File Name: openssl_0_9_8.nasl

Version: 1.7

Type: remote

Family: Web Servers

Published: 1/4/2012

Updated: 11/15/2018

Dependencies: openssl_version.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Ease: No exploit is required

Patch Publication Date: 7/5/2005

Vulnerability Publication Date: 9/16/2005

Reference Information

CVE: CVE-2005-2946

CWE: 310