OpenSSL < 0.9.7k / 0.9.8c PKCS Padding RSA Signature Forgery Vulnerability

Medium Nessus Plugin ID 17756


The SSL layer on the remote server does not properly verify signatures.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.7k or 0.9.8c.

These versions do not properly verify PKCS #1 v1.5 signatures and X509 certificates when the RSA exponent is 3.


Upgrade to OpenSSL 0.9.7k / 0.9.8c or later.

See Also

Plugin Details

Severity: Medium

ID: 17756

File Name: openssl_0_9_7k_0_9_8c.nasl

Version: $Revision: 1.9 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/09/05

Vulnerability Publication Date: 2006/09/05

Reference Information

CVE: CVE-2006-4339

BID: 19849

OSVDB: 28549

CERT: 845620

CWE: 310