OpenSSL < 0.9.7h / 0.9.8a Protocol Version Rollback

Medium Nessus Plugin ID 17755


The remote server is vulnerable to man-in-the-middle attacks.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.7h or 0.9.8a.

If the SSL_OP_MSIE_SSLV2_RSA_PADDING option is used, a remote attacker could force a client to downgrade to a weaker protocol and implement a man-in-the-middle attack.


Upgrade to OpenSSL 0.9.7h / 0.9.8a or later.

See Also

Plugin Details

Severity: Medium

ID: 17755

File Name: openssl_0_9_7h_0_9_8a.nasl

Version: $Revision: 1.7 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2005/10/11

Vulnerability Publication Date: 2005/10/11

Reference Information

CVE: CVE-2005-2969

BID: 15071

OSVDB: 19919