OpenSSL < 0.9.7c ASN.1 Decoding Vulnerabilities

critical Nessus Plugin ID 17753


Arbitrary code could be executed on the remote server.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.7c.

A remote attacker could trigger a denial of service or even execute arbitrary code by using an invalid client certificate.


Upgrade to OpenSSL 0.9.7c or later.

See Also

Plugin Details

Severity: Critical

ID: 17753

File Name: openssl_0_9_7c.nasl

Version: 1.13

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 1/4/2012

Updated: 8/21/2023

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2003-0543

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: installed_sw/OpenSSL

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/30/2003

Vulnerability Publication Date: 9/30/2003

Reference Information

CVE: CVE-2003-0543, CVE-2003-0544, CVE-2003-0545

BID: 8732

CWE: 119

CERT: 255484, 380864

CERT-CC: CA-2003-26