OpenSSL < 0.9.7c ASN.1 Decoding Vulnerabilities

Critical Nessus Plugin ID 17753


Arbitrary code could be executed on the remote server.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.7c.

A remote attacker could trigger a denial of service or even execute arbitrary code by using an invalid client certificate.


Upgrade to OpenSSL 0.9.7c or later.

See Also

Plugin Details

Severity: Critical

ID: 17753

File Name: openssl_0_9_7c.nasl

Version: $Revision: 1.11 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2003/09/30

Vulnerability Publication Date: 2003/09/30

Reference Information

CVE: CVE-2003-0543, CVE-2003-0544, CVE-2003-0545

BID: 8732

OSVDB: 3684, 3686, 3949

CERT-CC: CA-2003-26

CERT: 255484, 380864

CWE: 119