OpenSSL < 0.9.7-beta3 Buffer Overflow

High Nessus Plugin ID 17752


The remote server is affected by an arbitrary code execution vulnerability.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.7-beta3.

If Kerberos is enabled, a remote attacker could trigger a buffer overflow with a long master key and execute arbitrary code.


Upgrade to OpenSSL 0.9.7 or later.

Plugin Details

Severity: High

ID: 17752

File Name: openssl_0_9_7_beta3.nasl

Version: $Revision: 1.10 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2002/12/31

Vulnerability Publication Date: 2002/07/30

Reference Information

CVE: CVE-2002-0657

BID: 5361

OSVDB: 3942

CERT-CC: CA-2002-23

CERT: 561275