OpenSSL 0.9.6 CA Basic Constraints Validation Vulnerability

high Nessus Plugin ID 17751


The remote server is affected by a certificate validation vulnerability.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.7.

Such versions do not verify the Basic Constraint for some certificates. A remote attacker could perform a man-in-the-middle attack.

Details on this weakness are missing. It is related to CVE-2002-0970. OpenSSL 0.9.6 was reported as 'probably' vulnerable.


Upgrade to OpenSSL 0.9.7 or later.

See Also

Plugin Details

Severity: High

ID: 17751

File Name: openssl_0_9_7.nasl

Version: 1.7

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 1/4/2012

Updated: 8/22/2023

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 6.6


Risk Factor: High

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2009-0653

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: installed_sw/OpenSSL

Patch Publication Date: 12/31/2002

Vulnerability Publication Date: 7/25/2009

Reference Information

CVE: CVE-2009-0653

CWE: 287