OpenSSL 0.9.6 CA Basic Constraints Validation Vulnerability

High Nessus Plugin ID 17751


The remote server is affected by a certificate validation vulnerability.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.7.

Such versions do not verify the Basic Constraint for some certificates. A remote attacker could perform a man-in-the-middle attack.

Details on this weakness are missing. It is related to CVE-2002-0970. OpenSSL 0.9.6 was reported as 'probably' vulnerable.


Upgrade to OpenSSL 0.9.7 or later.

See Also

Plugin Details

Severity: High

ID: 17751

File Name: openssl_0_9_7.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Patch Publication Date: 2002/12/31

Vulnerability Publication Date: 2009/07/25

Reference Information

CVE: CVE-2009-0653

OSVDB: 56452

CWE: 287