OpenSSL < 0.9.6m / 0.9.7d Denial of Service

Medium Nessus Plugin ID 17750


The remote server is vulnerable to a denial of service attack.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.6m or 0.9.7d.

A remote attacker can crash the server by sending an overly long Kerberos ticket or a crafted SSL/TLS handshake.


Upgrade to OpenSSL 0.9.6m / 0.9.7d or later.

See Also

Plugin Details

Severity: Medium

ID: 17750

File Name: openssl_0_9_6m_0_9_7d.nasl

Version: $Revision: 1.8 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2004/03/17

Vulnerability Publication Date: 2004/03/17

Reference Information

CVE: CVE-2004-0079, CVE-2004-0112

BID: 9899

OSVDB: 4316, 4317

CERT: 484726