OpenSSL < 0.9.6l Denial of Service

Medium Nessus Plugin ID 17749


The remote server is vulnerable to a denial of service attack.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.6l.

A remote attacker can trigger a denial of service by using an invalid client certificate.


Upgrade to OpenSSL 0.9.6l or later.

See Also

Plugin Details

Severity: Medium

ID: 17749

File Name: openssl_0_9_6l.nasl

Version: $Revision: 1.7 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2003/11/04

Vulnerability Publication Date: 2003/11/04

Reference Information

CVE: CVE-2003-0851

BID: 8970

OSVDB: 2765

CERT: 412478