OpenSSL < 0.9.6k Denial of Service

medium Nessus Plugin ID 17748


The remote server is vulnerable to a denial of service attack.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.6k.

A remote attacker can trigger a denial of service by using an invalid client certificate.


Upgrade to OpenSSL 0.9.6k or later.

Plugin Details

Severity: Medium

ID: 17748

File Name: openssl_0_9_6k.nasl

Version: 1.14

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 1/4/2012

Updated: 8/22/2023

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2003-0543

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: installed_sw/OpenSSL

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/30/2003

Vulnerability Publication Date: 9/30/2003

Reference Information

CVE: CVE-2003-0543, CVE-2003-0544

BID: 8732

CERT: 255484, 380864

CERT-CC: CA-2003-26