OpenSSL < 0.9.6e Multiple Vulnerabilities

High Nessus Plugin ID 17746


The remote server is affected by multiple SSL-related vulnerabilities.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.6e. Such versions have the following vulnerabilities :

- On 64 bit architectures, these versions are vulnerable to a buffer overflow that leads to a denial of service. (CVE-2002-0655)

- Buffer overflows allow a remote attacker to execute arbitrary code. (CVE-2002-0656)

- A remote attacker can trigger a denial of service by sending invalid ASN.1 data. (CVE-2002-0659)


Upgrade to OpenSSL 0.9.6e or later.

Plugin Details

Severity: High

ID: 17746

File Name: openssl_0_9_6e.nasl

Version: $Revision: 1.11 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/02/22

Dependencies: 57323

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2002/07/30

Vulnerability Publication Date: 2002/07/30

Exploitable With


Core Impact

Reference Information

CVE: CVE-2002-0655, CVE-2002-0656, CVE-2002-0659

BID: 5362, 5363, 5364, 5366

OSVDB: 857, 3940, 3941, 3943

CERT-CC: CA-2002-23

CERT: 102795, 308891