Apache Struts < 2.5.31 / Denial of Service (S2-064)

high Nessus Plugin ID 177225


Apache Struts installed on the remote host is affected by Denial of Service vulnerability


The version of Apache Struts installed on the remote host is prior to 2.5.31 or It is, therefore, affected by a vulnerability as referenced in the S2-064 advisory.

- When a Multipart request has non-file normal form fields, Struts used to bring them into memory as Strings without checking their sizes. This could lead to OOM if developer has set struts.multipart.maxSize to a value equal or greater than the available memory. (CVE-2023-34396)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Struts version 2.5.31, or later. Alternatively, apply the workaround as referenced in in the vendor's security bulletin

See Also


Plugin Details

Severity: High

ID: 177225

File Name: struts_S2-064.nasl

Version: 1.6

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 6/13/2023

Updated: 9/21/2023

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2023-34396


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:struts

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 6/5/2023

Reference Information

CVE: CVE-2023-34396

IAVA: 2023-A-0287-S