Samba Winbind nss_info Extension Local Privilege Escalation

Medium Nessus Plugin ID 17719


The remote Samba server is affected by a local privilege escalation vulnerability.


According to its banner, the version of the Samba server installed on the remote host is affected by a local privilege escalation vulnerability. Specifically, the Winbind nss_info extension, when the 'winbind nss info' option is set to 'rfc2307' or 'sfu', grants local users the privileges of gid 0 if the 'RFC2307' or 'Services for UNIX' primary group attribute is not defined.


Upgrade to Samba version 3.0.26 or later.

See Also

Plugin Details

Severity: Medium

ID: 17719

File Name: samba_3_0_26.nasl

Version: $Revision: 1.5 $

Type: remote

Family: Misc.

Published: 2011/11/18

Modified: 2016/06/16

Dependencies: 10785

Risk Information

Risk Factor: Medium


Base Score: 6.9

Temporal Score: 5.7

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/09/11

Vulnerability Publication Date: 2007/09/11

Reference Information

CVE: CVE-2007-4138

BID: 25636

OSVDB: 39178

CWE: 264