ProFTPD < 1.3.1rc1 mod_ctrls Module pr_ctrls_recv_request Function Local Overflow

medium Nessus Plugin ID 17718
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote FTP server is affected by a local buffer overflow vulnerability.

Description

The remote host is using ProFTPD, a free FTP server for Unix and Linux.

According to its banner, the version of ProFTPD installed on the remote host is earlier than 1.3.1rc1 and is affected by a local, stack-based buffer overflow. The function 'pr_ctrls_recv_request' in the file 'src/ctrls.c' belonging to the 'mod_ctrls' module does not properly handle large values in the 'reqarglen' parameter.

This error can allow a local attacker to execute arbitrary code.

Solution

Upgrade to ProFTPD version 1.3.1rc1 or later.

See Also

https://www.securityfocus.com/archive/1/archive/1/454320/100/0/threaded

https://sourceforge.net/p/proftp/mailman/message/168826/

Plugin Details

Severity: Medium

ID: 17718

File Name: proftpd_1_3_1_rc1.nasl

Version: 1.7

Type: remote

Family: FTP

Published: 11/18/2011

Updated: 11/15/2018

Dependencies: ftpserver_detect_type_nd_version.nasl, ftp_overflow.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Medium

Base Score: 6.6

Temporal Score: 5.5

Vector: CVSS2#AV:L/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:proftpd:proftpd:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport, ftp/proftpd

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/12/2006

Vulnerability Publication Date: 12/12/2006

Exploitable With

Core Impact

Reference Information

CVE: CVE-2006-6563

BID: 21587

EDB-ID: 394, 3330, 3333