PHP 5.1.x < 5.1.2 Multiple Vulnerabilities

high Nessus Plugin ID 17712
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server uses a version of PHP that is affected by multiple vulnerabilities.


According to its banner, the version of PHP 5.1.x installed on the remote host is older than 5.1.2. Such versions may be affected by multiple vulnerabilities :

- A format string vulnerability exists in the error-reporting feature of the mysqli extension.

- Multiple HTTP response splitting vulnerabilities exist that would allow remote attackers to inject arbitrary HTTP headers via a crafted Set-Cookie header. (CVE-2006-0207)

- Multiple cross-site scripting vulnerabilities exist when display_errors and html_errors are on. (CVE-2006-0208)


Upgrade to PHP version 5.1.2 or later.

See Also

Plugin Details

Severity: High

ID: 17712

File Name: php_5_1_2.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 11/18/2011

Updated: 1/19/2021

Dependencies: php_version.nasl

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 1/12/2006

Vulnerability Publication Date: 1/11/2006

Reference Information

CVE: CVE-2006-0200, CVE-2006-0207, CVE-2006-0208

BID: 16220, 16803

CWE: 134